博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
5.12 Bfs
阅读量:5283 次
发布时间:2019-06-14

本文共 1739 字,大约阅读时间需要 5 分钟。

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:
 
N
 and
 
K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 
思路:
  Bfs
代码如下:
  

#include <iostream>

#include <queue>
#define MAX 100001
using namespace std;

int vis[MAX];

int ret[MAX];
queue <int> s;

int bfs(int a, int b)

{
 if(a == b)
 {
  return 0;
 }
 s.push(a);
 int cur;
 while (!s.empty())
 {
  cur = s.front();
  s.pop();
  if(cur + 1 < MAX && !vis[cur + 1])
  {
   s.push(cur + 1);
   ret[cur + 1] = ret[cur] + 1;
   vis[cur + 1] = 1;
  }
  if(cur + 1 == b)
  {
   break;
  }
  if(cur - 1 >= 0 && !vis[cur - 1])
  {
   s.push(cur - 1);
   ret[cur - 1] = ret[cur] + 1;
   vis[cur - 1] = 1;
  }
  if(cur - 1 == b)
  {
   break;
  }
  if(cur << 1 < MAX && !vis[cur << 1])
  {
   s.push(cur << 1);
   ret[cur << 1] = ret[cur] + 1;
   vis[cur << 1] = 1;
  }
  if(cur << 1 == b)
  {
   break;
  }
 }
 return ret[b];
}

int main()

{
 int a, b;
 cin >> a >> b;
 cout << bfs(a, b) << endl;
 return 0;
}

   

转载于:https://www.cnblogs.com/lihek/archive/2013/05/12/3074186.html

你可能感兴趣的文章
JavaScript压缩混淆 / 格式化 / 美化工具 - aTool在线工具
查看>>
第二章
查看>>
sql 对一张表进行按照不同条件进行多次统计
查看>>
多线程总结之旅(9):线程同步之事件
查看>>
C#基础知识之正则表达式
查看>>
Linux学习笔记(三)——权限管理
查看>>
python检测服务器是否ping通
查看>>
20172311 实验一《程序设计与数据结构》线性结构 实验报告
查看>>
Python--matplotlib绘图可视化知识点整理
查看>>
FTP知识集锦
查看>>
power designer简单教程
查看>>
Spring MVC静态资源处理(在applicationContex.xml文件中进行配置)
查看>>
POJ 3669 Meteor Shower【BFS】
查看>>
AOJ 0189 Convenient Location (Floyd)
查看>>
smarty模板自定义变量
查看>>
Windows下安装TensorFlow
查看>>
bootstraptable为行中的按钮添加事件
查看>>
POJ 1125 Stockbroker Grapevine 最短路 难度:0
查看>>
Topcoder 658 650 point
查看>>
HTML5新增
查看>>